Moo Wrapper runs 1 project on 2 GPU but gets stuck on 93.840%.

\n studio-striking\n

Message boards : Number crunching : Moo Wrapper runs 1 project on 2 GPU but gets stuck on 93.840%.
Message board moderation

To post messages, you must log in.

AuthorMessage
Sandman192
Avatar

Send message
Joined: 19 May 11
Posts: 6
Credit: 209,506,225
RAC: 0
Message 8514 - Posted: 6 Sep 2023, 5:10:55 UTC

I have 2 different NVIDIA cards "1080Ti and a 980. I've run this type of work before in Win 10 and Moo finished them.
Now it gets stuck and non of the GPUs are doing anything. I aborted it and have it try another task again.

Windows 11, BOINC 7.22.2, GPU driver 537.13, CUDA 12.2.0 Moo client 1.03 (cuda 31)
ID: 8514 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Link
Avatar

Send message
Joined: 11 Feb 14
Posts: 109
Credit: 7,625,123
RAC: 5,351
Message 8515 - Posted: 6 Sep 2023, 8:55:02 UTC - in response to Message 8514.  
Last modified: 6 Sep 2023, 9:02:23 UTC

I see one valid task in your list, run few more and see how they work. However it was running very slow, it needed about 86 seconds per block, my (single) ancient GTX 275 needs 15.5 seconds per block if I let it use a full CPU core, with CUDA client core #10 (nearly no CPU usage at all) it still needs just 17.5 seconds/block. Do you leave one CPU core free for it?

Maybe it's necessary for you to force the OpenCL version via app_info.xml. I've posted a working one for Linux in this message, for Windows you'll just need the right files and their names and of course the right platform name.
ID: 8515 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Sandman192
Avatar

Send message
Joined: 19 May 11
Posts: 6
Credit: 209,506,225
RAC: 0
Message 8516 - Posted: 7 Sep 2023, 4:34:41 UTC - in response to Message 8515.  

Na, I just not going to run Moo projects. I'm just not editing any setting just to get something to work. Moo! Wrapper need to fix this. I just want them to know there's a problem.
I did a few more and it got stuck the same way.
ID: 8516 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
[AF>EDLS]zOU

Send message
Joined: 13 Jun 16
Posts: 3
Credit: 951,216,310
RAC: 537
Message 8527 - Posted: 2 Dec 2023, 20:22:02 UTC - in response to Message 8516.  

Same here.

1 WU runs on 2 GPU.

Weird
That's a GTX980 and a GTX980 Ti
Detected as 2x GTX989Ti (???)

Results:

https://moowrap.net/results.php?hostid=1300227&offset=0&show_names=1&state=4&appid=

Not sure if it makes a difference for credits ?
ID: 8527 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
[AF>EDLS]zOU

Send message
Joined: 13 Jun 16
Posts: 3
Credit: 951,216,310
RAC: 537
Message 8528 - Posted: 2 Dec 2023, 22:21:34 UTC - in response to Message 8527.  

these 2 also have 2 GPU but run 1WU / GPU.....

https://moowrap.net/show_host_detail.php?hostid=1317434
https://moowrap.net/show_host_detail.php?hostid=1326673
ID: 8528 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Link
Avatar

Send message
Joined: 11 Feb 14
Posts: 109
Credit: 7,625,123
RAC: 5,351
Message 8529 - Posted: 3 Dec 2023, 9:48:13 UTC - in response to Message 8527.  

Not sure if it makes a difference for credits ?
No, you get simply 8 credits per crunched block.
ID: 8529 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Link
Avatar

Send message
Joined: 11 Feb 14
Posts: 109
Credit: 7,625,123
RAC: 5,351
Message 8530 - Posted: 3 Dec 2023, 10:01:00 UTC - in response to Message 8528.  

https://moowrap.net/show_host_detail.php?hostid=1317434
https://moowrap.net/show_host_detail.php?hostid=1326673

Because they run the OpenCL and not the CUDA app, OpenCL uses only one GPU per task. You can create an app_info.xml file to run only the OpenCL app as suggested above, if you post the file names for all files that belong to that application (like in the Linux thread), I can help you with that (my GTX 275 runs only the CUDA app, so I don't have the files for the OpenCL app).
ID: 8530 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
[AF>EDLS]zOU

Send message
Joined: 13 Jun 16
Posts: 3
Credit: 951,216,310
RAC: 537
Message 8531 - Posted: 4 Dec 2023, 6:34:37 UTC - in response to Message 8530.  

thx, the machine did get some opencl tasks and yes they run 1WU/GPU.

I'll give it a go
ID: 8531 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
TheFanMan64

Send message
Joined: 12 Dec 20
Posts: 28
Credit: 92,633,350
RAC: 236,031
Message 8560 - Posted: 3 Feb 2024, 5:18:00 UTC
Last modified: 3 Feb 2024, 5:18:32 UTC

I used to have the same issue on a spesific machine, it has a GTX 760 and a GT 730, runs fine all the way up to about 93% where according to msi afterburner, the gtx 760 stops computing and the 730 is left computing alone for a while, this has since stopped an
d it now sends single tasks for each card.
ID: 8560 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Sandman192
Avatar

Send message
Joined: 19 May 11
Posts: 6
Credit: 209,506,225
RAC: 0
Message 8569 - Posted: 4 Feb 2024, 5:19:57 UTC - in response to Message 8560.  

I used to have the same issue on a spesific machine, it has a GTX 760 and a GT 730, runs fine all the way up to about 93% where according to msi afterburner, the gtx 760 stops computing and the 730 is left computing alone for a while, this has since stopped an
d it now sends single tasks for each card.

Thank for the update. I'll try it again.
ID: 8569 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Sandman192
Avatar

Send message
Joined: 19 May 11
Posts: 6
Credit: 209,506,225
RAC: 0
Message 8570 - Posted: 5 Feb 2024, 15:08:36 UTC - in response to Message 8569.  

No. Projects still get stuck 98% now.
Remaining time is over an 1hr. Was only 4:43 when started.
21hrs go by then I aborted.
Running 2 GPUs for 1 Project.
I have a GTX 1080 and 980.

If project can't run on 2 different GPUs then exclude projects when 2 GPUs don't match. But still gather work but make it run 1 GPU at a time when GPUs don't match.
Or find a way to have 1 project work together on 2 different GPUs.

I will not change any settings for work arounds because we shouldn't have to mess with settings when it should be a set it and forget it.
And if problem arises then report.

Ok, after creating this message I let 1 more Moo project run 1 PJ on 2 GPUs and finish at 4:43.
I still have plenty of projects to run but I'm going to about if 1 of them goes over 6 mins.
Seem like an on and off issue.
ID: 8570 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : Moo Wrapper runs 1 project on 2 GPU but gets stuck on 93.840%.


 
Copyright © 2011-2024 Moo! Wrapper Project