FreeBSD Wrapper

\n studio-striking\n

Questions and Answers : Unix/Linux : FreeBSD Wrapper
Message board moderation

To post messages, you must log in.

AuthorMessage
Zolotkey
Avatar

Send message
Joined: 18 Jul 19
Posts: 2
Credit: 353,664
RAC: 0
Message 8139 - Posted: 19 Jul 2019, 17:30:25 UTC

Hello,

I just setup Boinc client on my FreeBSD server. I noticed that distributed.net has a FreeBSD 10.3+ application. I signed up for Moo! wrapper hoping that my FreeBSD server could try and run the FreeBSD application or at least the Linux Emulation. Yesterday was my first day trying to compute with Boinc. It downloads the linux binaries but errors out. Is it possible to find what libraries are required for Linux so that I may install them in compat/linux/ for my FreeBSD version?

I am running FreeBSD 12.

Any help would be appreciated.

Thank you
ID: 8139 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Zolotkey
Avatar

Send message
Joined: 18 Jul 19
Posts: 2
Credit: 353,664
RAC: 0
Message 8140 - Posted: 20 Jul 2019, 0:40:58 UTC

II got it working..

Just needed to load the linproc filesystem, and brand the linux binary with this command
brandelf -t Linux
ID: 8140 · Rating: 0 · rate: Rate + / Rate - Report as offensive

Questions and Answers : Unix/Linux : FreeBSD Wrapper


 
Copyright © 2011-2021 Moo! Wrapper Project