2nd GPU issue

Questions and Answers : Windows : 2nd GPU issue
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile UBT - Mikeejones

Send message
Joined: 20 May 11
Posts: 3
Credit: 54,709,171
RAC: 17,673
Message 7782 - Posted: 6 Nov 2017, 20:24:44 UTC

Hi

I've running a Ryzen 7 m/board with 2 X GTX1060's - both 3GB versions, one an ASUS, the other Zotac.

Up to last week I had just the 1 1060 and WUs were taking around 2000 seconds which was fine.

I added the 2nd 1060 at the weekend expecting either to have 2 WUs running at the same time or 1 WU with the workload shared between the 2 cards.
As you'll all ready know, the second option works here. However, I got a problem. The first WU unit completes in around 900 seconds, but every one after that takes around 2000 seconds. This has happened twice now - it's as if the cards are doing the same work twice rather than sharing.

Any ideas on how to get them to play nicely?

Mike
ID: 7782 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile UBT - Mikeejones

Send message
Joined: 20 May 11
Posts: 3
Credit: 54,709,171
RAC: 17,673
Message 7783 - Posted: 7 Nov 2017, 9:20:24 UTC - in response to Message 7782.  
Last modified: 7 Nov 2017, 9:22:59 UTC

Hi

Right sorted it!

Tasks ARE taking just 17 minutes.

Take a look at this WU https://moowrap.net/result.php?resultid=63919674
CPU and run time is 31 mins 38 seconds, but if you look at the start and finish times (8:57 to 9:14) it's 17 mins. I was watching the WU in the manager and couldn't understand why it was at 90% at around 10 mins.

So Moo seems to have a error at their side!

Mike
ID: 7783 · Rating: 0 · rate: Rate + / Rate - Report as offensive
QuintLeo

Send message
Joined: 26 Jun 16
Posts: 53
Credit: 1,866,706,325
RAC: 0
Message 7786 - Posted: 8 Nov 2017, 4:58:15 UTC - in response to Message 7783.  

Even when running the actual DNet client, 2 GPUs won't "share work" - they are always working on different keyblocks.
What you *should* be seeing is each GPU working on a seperate workunit, and taking about the same time that they did before.
ID: 7786 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile UBT - Mikeejones

Send message
Joined: 20 May 11
Posts: 3
Credit: 54,709,171
RAC: 17,673
Message 7797 - Posted: 10 Nov 2017, 22:01:23 UTC - in response to Message 7786.  
Last modified: 10 Nov 2017, 22:03:03 UTC

Even when running the actual DNet client, 2 GPUs won't "share work" - they are always working on different keyblocks.
What you *should* be seeing is each GPU working on a seperate workunit, and taking about the same time that they did before.


Hi

That would assume that there would be 2 Work Units (1 for each GPU) running at the same time, this is not the case. Each Work Unit is using 2 GPUs at the same time. I assume that they totalled the time for the 2 GPUs to complete but even if you double the time taken it nearly works but doesn't quite. If they did then it would explain everything.

Mike
ID: 7797 · Rating: 0 · rate: Rate + / Rate - Report as offensive
mikey
Avatar

Send message
Joined: 22 Jun 11
Posts: 2063
Credit: 1,000,866,048
RAC: 0
Message 7800 - Posted: 11 Nov 2017, 14:28:07 UTC - in response to Message 7797.  

Even when running the actual DNet client, 2 GPUs won't "share work" - they are always working on different keyblocks.
What you *should* be seeing is each GPU working on a seperate workunit, and taking about the same time that they did before.


Hi

That would assume that there would be 2 Work Units (1 for each GPU) running at the same time, this is not the case. Each Work Unit is using 2 GPUs at the same time. I assume that they totalled the time for the 2 GPUs to complete but even if you double the time taken it nearly works but doesn't quite. If they did then it would explain everything.

Mike


Boinc isn't set up to do that though, it can't share workunits across gpu's like it can for cpu units across cpu cores. It sounds more like one gpu isn't working on the workunit while the other is being slow.
ID: 7800 · Rating: 0 · rate: Rate + / Rate - Report as offensive

Questions and Answers : Windows : 2nd GPU issue


 
Copyright © 2011-2019 Moo! Wrapper Project