Credit

Questions and Answers : Windows : Credit
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile Dan T. Morris
Avatar

Send message
Joined: 15 May 11
Posts: 6
Credit: 272,956,588
RAC: 0
Message 512 - Posted: 28 May 2011, 5:05:57 UTC

Look at these wu's low credits?

http://moowrap.net/result.php?resultid=375770

DD
ID: 512 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Dan T. Morris
Avatar

Send message
Joined: 15 May 11
Posts: 6
Credit: 272,956,588
RAC: 0
Message 513 - Posted: 28 May 2011, 5:28:22 UTC - in response to Message 512.  

Well I found the reason. For some reason my cpu yes was checked.

DD
ID: 513 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Clod PatryProject donor
Volunteer moderator
Volunteer developer
Volunteer tester

Send message
Joined: 2 May 11
Posts: 65
Credit: 242,754,987
RAC: 0
Message 514 - Posted: 28 May 2011, 5:47:54 UTC

exactly, the CPU is enable by default (this will maybe change btw).

If you look for your tasks with Distributed.net Client v1.02 (ati14) app, this takes much less cpu time and give much more credits.

ID: 514 · Rating: 0 · rate: Rate + / Rate - Report as offensive
blackheeler

Send message
Joined: 2 May 11
Posts: 3
Credit: 1,502,947
RAC: 0
Message 556 - Posted: 1 Jun 2011, 9:40:31 UTC

Not so, I'm getting the same (low) credit for both CPU and GPU tasks. Issue still persists after detach/reattach from project..........

http://moowrap.net/workunit.php?wuid=410582

http://moowrap.net/workunit.php?wuid=323091
ID: 556 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile ZydorProject donor
Avatar

Send message
Joined: 5 May 11
Posts: 233
Credit: 351,414,150
RAC: 0
Message 557 - Posted: 1 Jun 2011, 10:08:18 UTC - in response to Message 556.  

Not so, I'm getting the same (low) credit for both CPU and GPU tasks. Issue still persists after detach/reattach from project..........

http://moowrap.net/workunit.php?wuid=410582

http://moowrap.net/workunit.php?wuid=323091


Your credits are correct. The first is a (small) GPU WU of 12 Stat Units, x8.5 per stat unit = 102

The second is a CPU WU, again the credits are correct, same calculation.

Your focus should be on what the server is sending you. At present you are getting small WUs for a 58XX class card, you should be getting bigger size WUs. You dont lose credits as such because the app scales well, x8.5 credits per Stat Unit. I've seen this happen recently with someone else. Run the WUs out for an hour or so, see if the smaller ones run out and start being replaced by larger ones - however, you are not losing many credits against the norm - a few for more load/unloads, but not that many.

Your other issue is by running CPU WUs against all CPU cores, you will strangle the GPU application. Keep one CPU core free for each GPU thats running - for 5970 owners reading this, that includes 5970s where two CPU cores need keeping free to release the card to full use. With the latter though, watch the VRM temperatures, which will increase markedly if an overclock is in place, its likely the GPU will need downclocking a fair bit to bring all back in balance.

Lastly be wary of the GPU timing shown in the Account Task Page - its incorrect for many people. The correct timing is shown inside the stderr file at the bottom (the summary line).

Regards
Zy
ID: 557 · Rating: 0 · rate: Rate + / Rate - Report as offensive
ConanProject donor
Avatar

Send message
Joined: 2 May 11
Posts: 51
Credit: 251,207,221
RAC: 0
Message 558 - Posted: 1 Jun 2011, 10:09:29 UTC - in response to Message 556.  

Not so, I'm getting the same (low) credit for both CPU and GPU tasks. Issue still persists after detach/reattach from project..........

http://moowrap.net/workunit.php?wuid=410582

http://moowrap.net/workunit.php?wuid=323091



Hey Clod, looks like Blackheeler has been given CPU credit on a GPU work unit, both work units got 102 credits. Validator issue I believe.

Conan
ID: 558 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile ZydorProject donor
Avatar

Send message
Joined: 5 May 11
Posts: 233
Credit: 351,414,150
RAC: 0
Message 559 - Posted: 1 Jun 2011, 10:15:11 UTC - in response to Message 558.  

No its not validator - look inside his stderr's - he is getting 12 Stat Unit sized WUs, so credits are correct

Regards
Zy
ID: 559 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Teemu Mannermaa
Project administrator
Project developer
Project tester

Send message
Joined: 20 Apr 11
Posts: 360
Credit: 755,796,644
RAC: 100,183
Message 572 - Posted: 2 Jun 2011, 12:56:32 UTC - in response to Message 556.  

Not so, I'm getting the same (low) credit for both CPU and GPU tasks. Issue still persists after detach/reattach from project..........


Looks like another PFC scaling issue, where scheduler is thinking your host is slow and so is sending tiny work units to it. This should clear up as soon as you return enough work units to determine it's actual speed. As such, detach/reattach is something that shouldn't be done because that resets the history statistics.

I'll see if I can improve this PFC scaling (maybe I'll just disable it as it's just giving more problems than fixing things).

-w
ID: 572 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile ZydorProject donor
Avatar

Send message
Joined: 5 May 11
Posts: 233
Credit: 351,414,150
RAC: 0
Message 577 - Posted: 2 Jun 2011, 16:01:06 UTC - in response to Message 572.  

..... I'll see if I can improve this PFC scaling (maybe I'll just disable it as it's just giving more problems than fixing things)...


Would be a shame to lose it, its a welcome flexible facility - maybe a Sticky Post "Titled 102 Credit WUs" would help for now until you nail the bugs.

Regards
Zy
ID: 577 · Rating: 0 · rate: Rate + / Rate - Report as offensive
blackheeler

Send message
Joined: 2 May 11
Posts: 3
Credit: 1,502,947
RAC: 0
Message 581 - Posted: 3 Jun 2011, 12:16:43 UTC - in response to Message 572.  

Looks like another PFC scaling issue, where scheduler is thinking your host is slow and so is sending tiny work units to it. This should clear up as soon as you return enough work units to determine it's actual speed.


I'm guessing the 500+ tiny WU's I have received and returned in the 2 days since my first post still don't qualify as "enough" to deserve bigger WU's?
ID: 581 · Rating: 0 · rate: Rate + / Rate - Report as offensive
Profile Teemu Mannermaa
Project administrator
Project developer
Project tester

Send message
Joined: 20 Apr 11
Posts: 360
Credit: 755,796,644
RAC: 100,183
Message 594 - Posted: 4 Jun 2011, 15:29:32 UTC - in response to Message 581.  

I'm guessing the 500+ tiny WU's I have received and returned in the 2 days since my first post still don't qualify as "enough" to deserve bigger WU's?


I just noticed that upstream (BOINC devs) has fixed a bug in this PFC scaling and I'm about to push that update live. Hopefully this means scheduler will finally believe you have fast host and starts sending huge work units for you too.

-w
ID: 594 · Rating: 0 · rate: Rate + / Rate - Report as offensive
blackheeler

Send message
Joined: 2 May 11
Posts: 3
Credit: 1,502,947
RAC: 0
Message 599 - Posted: 5 Jun 2011, 5:16:23 UTC - in response to Message 594.  

Thank you Teemu, the larger WU's are coming through now :-)
ID: 599 · Rating: 0 · rate: Rate + / Rate - Report as offensive

Questions and Answers : Windows : Credit


 
Copyright © 2011-2017 Moo! Wrapper Project