Latest ATI/nVidia requirements

Message boards : Status info : Latest ATI/nVidia requirements
Message board moderation

To post messages, you must log in.

AuthorMessage
Profile Teemu Mannermaa
Project administrator
Project developer
Project tester

Send message
Joined: 20 Apr 11
Posts: 360
Credit: 755,976,052
RAC: 110,645
Message 329 - Posted: 15 May 2011, 22:33:18 UTC
Last modified: 23 May 2015, 8:33:31 UTC

AMD/ATI OpenCL requirements:

  • BOINC Client v7.2.28 or later
  • Minimum OpenCL v1.1
  • Requires OpenCL driver version newer than 1084.4 (which means Catalyst 13.4 or newer)
  • Minimum device memory 32M, but should only allocate about 8M


AMD/ATI Stream requirements:


  • BOINC Client v7.2.28 or later for app v1.4 and BOINC Client v6.10.22 or later for app v1.3
  • Driver v10.4 or later
  • Minimum device memory 32M, but should only allocate about 8M
  • Maximum CAL target is 20 for Tahiti based cards (AMD Radeon HD 7870/7950/7970/R9 280X series) as OpenCL is preferred for newer cards
  • ATI Runtime (not older AMD)
  • Disable CrossFireX for performance reasons (some users report that they have had success with CrossFireX enabled so your mileage may vary)


nVidia OpenCL requirements:


  • BOINC Client v7.2.28 or later
  • Minimum OpenCL v1.1
  • Minimum device memory 64M (measured to use only 29MB for tiny work units)


nVidia CUDA requirements:


  • BOINC Client v6.10.22 or later
  • Driver v256.00 or later (recommendation is at least v257.21, which is latest for this family of drivers)
  • Minimum device memory 64M (measured to use only 29MB for tiny work units)
  • CUDA Runtime v3.1 or above
  • Compute Capability 1.0 or higher (basically all CUDA capable cards)


Changes:
16. May 2011: 1) BOINC Client v6.10.22 required because it's the first version that has coproc information available to applications. (Not yet enforced.) 2) It's recommended to disable CrossFireX for ATI because it might cause a major performance degradation.
19. May 2011: BOINC Client v6.10.22 is now enforced as of application v1.2.
24. May 2011: After testing and verification (thanks terencewee*), CUDA memory requirement lowered to 64M from 384M.
6. Sep 2014: ATI Stream memory requirement now only 32M (was 250M) and BOINC Client v7.2.28 or later required for app v1.4 because that's first version that has coproc information available for us.
7. Sep 2014: Documented CAL target 20 requirement for Stream.
14. Sep 2014: AMD/ATI OpenCL requires Catalyst v13.4 or newer.
23. May 2015: Added nVidia OpenCL requirements.

-w

ID: 329 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile [AF>EDLS] Polynesia
Avatar

Send message
Joined: 1 May 11
Posts: 23
Credit: 1,574,433
RAC: 0
Message 333 - Posted: 16 May 2011, 14:22:00 UTC

Most of the people are not already in 6.10.58 or 60?

I am 6.12.26 ...

Config : i7 860 2.8ghz, 8g ram, boinc : 6.12.26, GPU : GTX 470 Zotac Amp Edition 1280 mo DDR5
ID: 333 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Clod PatryProject donor
Volunteer moderator
Volunteer developer
Volunteer tester

Send message
Joined: 2 May 11
Posts: 65
Credit: 242,754,987
RAC: 0
Message 351 - Posted: 17 May 2011, 20:30:53 UTC

version 6.12.16 has been released to public.
This is the first version in the 6.12 branch which is public release.

So update when you get time.
ID: 351 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile Teemu Mannermaa
Project administrator
Project developer
Project tester

Send message
Joined: 20 Apr 11
Posts: 360
Credit: 755,976,052
RAC: 110,645
Message 375 - Posted: 19 May 2011, 1:08:46 UTC - in response to Message 351.  

version 6.12.16 has been released to public.
This is the first version in the 6.12 branch which is public release.


That's BOINC Client v6.12.26, which is indeed first public 6.12 branch release. :)

-w
ID: 375 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
QuintLeo

Send message
Joined: 26 Jun 16
Posts: 36
Credit: 1,223,462,042
RAC: 8,677,337
Message 7757 - Posted: 27 Oct 2017, 4:02:42 UTC - in response to Message 375.  

The distributed.net client ITSELF does not support NVidia well if at all in versions prior to 521.
Yet another reason MooWrapper NEEDS to get updated to 521 asap - it fixed a TON of issues vs the version 520 client MooWrapper is currently using, and offers a LOT better performance on NVidia cards.
ID: 7757 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Status info : Latest ATI/nVidia requirements


 
Copyright © 2011-2017 Moo! Wrapper Project