Transitioner problem solved

log in

Advanced search

Message boards : News : Transitioner problem solved

Author Message
Teemu Mannermaa
Project administrator
Project developer
Project tester
Send message
Joined: 20 Apr 11
Posts: 355
Credit: 722,726,817
RAC: 160,739
Message 4942 - Posted: 22 May 2013, 17:05:39 UTC

It turned out the problem was actually caused by a corrupted index in one of the primary database tables used by BOINC Server. Recreated the table/index and things are looking much better so I've restarted the system. However, transitioner is now going through all the 600k workunits in the DB and only once that is done, the system will start creating new workunits. Until then we are out of work to send. Sorry! I'll keep an eye out to make sure we recover fully.

BarryAZ
Send message
Joined: 20 Jun 11
Posts: 34
Credit: 1,123,062,447
RAC: 7,060
Message 4944 - Posted: 22 May 2013, 18:50:32 UTC - in response to Message 4942.
Last modified: 22 May 2013, 19:30:26 UTC

OK -- thanks for the report back. For what it is worth, it has been about an hour since you reported that you'd identified the issue and resolved it and I've not yet seen any movement in my credits -- I have 220 Pending work units (I didn't check to see if that number was higher last night). But my credit count remains where it was last night.

BarryAZ
Send message
Joined: 20 Jun 11
Posts: 34
Credit: 1,123,062,447
RAC: 7,060
Message 4945 - Posted: 23 May 2013, 2:31:01 UTC - in response to Message 4944.

The pendings appear to be dropping -- but VERY slowly. I suspect there is another (or a related) issue here. Perhaps it is a function of having so very many backlogged units to process. Perhaps there is either some disk churning going on here or simply a lack of memory to process things efficiently. Just guessing here --- but it has been a good five hours and the progress seems to be glacial.

I suspended processing on all but one workstation (couldn't get to it), as reporting additional completed work units is not likely to help matters.

BarryAZ
Send message
Joined: 20 Jun 11
Posts: 34
Credit: 1,123,062,447
RAC: 7,060
Message 4950 - Posted: 23 May 2013, 18:11:32 UTC - in response to Message 4945.

The backlog has been cleared -- excellent.

valterc
Send message
Joined: 10 May 11
Posts: 17
Credit: 1,209,524,639
RAC: 107,892
Message 4970 - Posted: 28 May 2013, 15:25:39 UTC - in response to Message 4950.

I have one (just one) wu in 'pending validation' state since the 23rd of May. This: http://moowrap.net/results.php?userid=1662&offset=0&show_names=1&state=2&appid=. Maybe there are others around...

BarryAZ
Send message
Joined: 20 Jun 11
Posts: 34
Credit: 1,123,062,447
RAC: 7,060
Message 5156 - Posted: 4 Jul 2013, 17:27:07 UTC - in response to Message 4970.

Looks like the problem has resurfaced -- awaiting validation are climbing again

Message boards : News : Transitioner problem solved


Main page · Your account · Message boards


Copyright © 2011-2017 Moo! Wrapper Project